
Reports 
A report is an object in Microsoft Access that is used to display and print your data in an organized 
manner. 
A report consists of information that is pulled from tables or queries, as well as information that is stored 
with the report design, such as labels, headings, and graphics. Reports offer a way to view, format, and 
summarize the information in your Microsoft Access database. The tables or queries that provide the 
underlying data are also known as the report's record source. For example, you can create a simple 
report of phone numbers for all your contacts, or a summary report on the total sales across different 
regions and time periods. 
Parts of a report 
A report is bound to a data source such as a table or query. The design of a report is divided into sections 
that you can view in the Design view. Understanding how each section works can helps you create better 
reports. The following list is a summary of the section types and their uses: 

Section How the section is displayed when printed When the section can be used 

Report Header At the beginning of the report 
Use the report header for information that might 

normally appear on a cover page, such as a logo, 
a title, or a date. The report header is printed 

before the page header. 
Page Header At the top of every page Use a page header to repeat the report title on 

every page. 

Group Header At the beginning of each new 
groups of records 

Use the group header to print the group name. For 
example, in a report that is grouped by product, 
use the group header to print the product name. 

You can have multiple group header sections on a 
report, depending on how many grouping levels 

you have added. 
Detail Appears once for every row in 

the record source 
This is where you place the controls that make up 

the main body of the part. 

Group footer At the end of each group of 
records. 

Use a group footer to print summary information 
for a group. You can have multiple group footer 
sections on a report, depending on how many 

grouping levels you have added. 
Page Footer At the end of every page Use a page footer to print page number 

Report Footer At the end of the report Use the report footer to print report totals or other 
summary information for the entire report. 

 
Create a report in Access 

We can create reports for Access desktop database by following these steps: 
Step 1: Choose a record source 

 The record source of a report can be a table, a named query, or an embedded query. The record 
source must contain all of the rows and columns of data you want display on the report. 

 If the data is from an existing table or query, select the table or query in the Navigation Pane, and 
then continue to Step 2. 

 If the record source does not yet exist, do one of the following: 
 Continue to Step 2 and use the Blank Report tool, 



Or 
 Create the table(s) or query that contains the required data. Select the query or table in the 

Navigation Pane, and then continue to Step 2. 
Step 2: Choose a report tool 
The report tools are located on the Create tab of the ribbon, in the Reports group. The following table 
describes the options: 

Tool Description 
Report Creates a simple, tabular report containing all of the fields in the record 

source you selected in the Navigation Pane. 
Report Design Opens a blank report in Design view, to which you can add the required 

fields and controls. 
Blank Report Opens a blank report in Layout view, and displays the Field List from where 

you can add fields to the report 
Report Wizard Displays a multiple-step wizard that lets you specify fields, grouping/sorting 

levels, and layout options. 
Labels Displays a wizard that lets you select standard or custom label sizes, as well 

as which fields you want to display, and how you want them sorted. 
 
Step 3: Create the report 

1. Click the button for the tool you want to use. If a wizard appears, follow the steps in the wizard 
and click Finish on the last page.  Access displays the report in Layout view. 

2. Format the report to achieve the looks that you want: 
 Resize fields and labels by selecting them and then dragging the edges until they are the size 

you want. 
 Move a field by selecting it (and its label, if present), and then dragging it to the new location. 
 Right-click a field and use the commands on the shortcut menu to merge or split cells, delete 

or select fields, and perform other formatting tasks. 
Create a Report with the Report Wizard in Microsoft Access 

Similar to the Form Wizard, the Report Wizard walks you through a series of decisions in order to build a 
report. To create a report using the Report Wizard, follow the steps below: 

1. On the Create tab in the Reports group, click Report Wizard. The wizard starts. 
 

  
2. From the Tables/Queries drop-down list, select the table (or query) to base the report on. The 

fields for the selected table load in the Available Fields list box. 



 
3. Move the fields to include on the report from the Available Fields list box to the Selected Fields 

list box. To do so, double-click a field name to move it or highlight the field name and click >. To 
move all fields at once, click >>. 
 

  
4. Click Next >. 

  
5. To group records on the report by a particular field, highlight the field in the list box and click >. 

 

  
6. Add more grouping levels if desired. You can use the arrows to change the order of the grouping 

levels if needed. 
 

7. When you finish defining how you want records grouped, click Next > 
 



  
8. In the first drop-down list, select the field to sort records by. By default, records will be sorted in 

ascending order by the field you select. If you want to sort in descending order, click the 
Ascending button to change its label to "Descending". 
 

  
9. You can specify up to four levels of sorting. When you finish specifying sorting options, click Next 

>. 

  
10. In the Layout field, select the format of the report. The  options are "Stepped", "Block", and 

"Outline". (Try the options to see a preview of the report layouts.) 
 

11. In the Orientation field, select whether to lay out the report in portrait or landscape mode. 
 



12. If you want all fields to fit on a single page, ensure the Adjust the field width so all fields fit on a 
page check box is marked. 
 

13. Click Next >. 
 

  
14. Enter a title for the report. 

 
15. Select an option for the view you want to open the report in. Your options are: 

 Preview the report (opens in Print Preview mode). 
 Modify the report's design (opens in Design view). 

16. Click Finish. The report loads in the view you selected 

 



  
Once the wizard has done its job, future changes to the Sorting and Grouping are made in the 
Group, Sort, and Total area: Design > Group & Sort. You may change the order of, remove, or 
edit any existing items. You may also add a group and a sort as well. 
 

 
Formatting Reports 

One of the strengths of reports is that you can modify their appearance to make them look how you want. 
You can add headers and footers, apply new colors, and even add a logo. All of these things can help 
you create visually appealing reports. 
Modifying report text 
The bulk of the information in your report comes straight from the query or table you built it from, which 
means you can't edit it within the report. However, you can change, add, or delete label text, headers, and 
footers to make your report clearer and easier to read. For example, in our report we decided we didn't 
need the field headings to understand our data, so we simply deleted them. 
Access allows us to modify the text color and font, add shapes, and more.  
 
 



Modifying the page header and footer 
To view and modify the header and footer that appear on each page of your report, select the View 
command on the Ribbon and switch to Design view. The header and footer are located in the white space 
beneath the Page Header and Page Footer bars. 
Depending on our report's design, sometimes we may find that there is no white space in the page 
header and footer.  If this is the case, we must resize the header and footer before adding  anything to 
them. Simply click and drag the bottom border of the header or footer to make it larger. 
To add text to a header or footer: 

1. Select the Design tab, locate the Controls group, and click the Label command. 

  
2. Click and drag the mouse inside the white area to create your label. Release the mouse when it is 

the desired size. 

  
3. Click the text box, and type the desired text. 

  
To add the date and time to a header or footer: 

1. Select the Design tab, locate the Header/Footer group, and click the Date and Time command. 



 
 
2. A dialog box will appear. Select the desired formatting options. A preview of the text that will be 

included in your report will appear. 
3. When you are satisfied with the appearance of the date and time, click OK. 

 
By default, the date and time appear in the header. If you would like to move them to the footer instead, 
simply click the date and time boxes and drag them to the desired location. 
To add page numbers to a header or footer: 

1. Select the Design tab, then locate the Header/Footer group. 
2. Click the Page Numbers command. 

  
3. The Page Numbers dialog box will appear. Under Format, choose Page N to display the number 

of only the current page, or Page N of M to display the number of the current page and the 
number of total pages. 

4. Under Position, choose Top of Page or Bottom of Page to control where the page numbers 
appear. 

5. Click the drop-down arrow to select the alignment of the page numbers. 
6. When you are satisfied with the settings, click OK. 



 
Modifying your report's appearance 
To add a logo: 

1. From the Design tab, click the View command, then select Layout View from the drop-down list. 

  
2. Locate the Header/Footer group, then click the Logo command. 

  
3. A dialog box will appear. Locate and select the desired file, then click OK to add it to your report. 

 



4. A small version of the image will appear in the header. Click and drag the image border to resize 
it. 

 
 
5. If necessary, move your logo to the desired location by clicking and dragging it. 

  
Themes and fonts 
Designing and modifying reports using theme elements can help you keep the appearance of your reports 
consistent. 
To change the theme: 

1. Select the Design tab, locate the Themes group, and click the Themes command. 

 
2. A drop-down menu will appear. Select the desired theme. 

 



3. The theme will be applied to your entire database. 
To change the theme fonts: 

1. Select the Design tab, locate the Themes group, and click the Fonts command. 

  
2. A drop-down menu will appear. Select a set of theme fonts. 

 
3. The fonts will be applied to your entire database. 

Creating a report manually 
1. Under “Microsoft Access Create”, click to Report Design. 
2. You are viewing the report in what is called Design View. It should look very similar to the screen 

shot below: 
 

  



3. Click on the Property Sheet from the Microsoft Access Design Ribbon (in Tools group). The 
Properties window for the Report object should appear and resemble the screen capture below. 
 

  
4. Set the Record source property.  The purpose of the Record Source property is to set the source 

of the data for the report. We can set the Record Source property to a table name, a query name, 
or we can build our own SQL statement by invoking the Query Builder. We can invoke Query 
Builder by clicking on the button with the three dots to the right of the Record Source property. 

5. A pop up window with the title of ‘Show Table’ will appear. Under the ‘Tables’ tab, select the table 
or tables that contain data you would like to see on your report.  

6. Once all of the tables have been added, click the Close Button. The ‘Query Builder’ screen should 
appear. 

7. Using this screen, we can now begin to build our SQL statement that will be used to populate our 
report.  

8. When you click on the X button on the top right of the window, the following message will appear: 
 

  
9. When this message box appears, click the Yes button. 
10. When you return to the Properties window for the Report object, you will see the SQL details in 

the Record Source field. 
 

 



 
11. Set the caption Property. Caption is the name that displays in the title bar at the very top of the 

report. A title bar at the top of the report displays the value that was set in the Caption field. 
12. When you return to the Properties window for the Report object, you will see the SQL details in 

the Record Source field. Now that you have identified which table or tables to select data from, 
objects need to be added from the table(s) to the report. Access provides a very nice feature that 
allows you to easily select which objects you would like to appear on your report. In the ribbon at 
the top of the page, click on the Design tab and then on the button called ‘Add Existing Fields’. 
 

  
13. A small window will appear based on the Record Source selected earlier: 

 

  
14. All of the fields that are available for use will be listed. To select one of these fields to be added to 

your report, highlight the object in the window, and then drag it to the location in the report where 
you would like this object to appear. 
 

  
15. You will probably need to resize the object. To resize, click on the object that you wish to resize. 

You will notice small boxes around the perimeter of the object like in the example below. 



  
16. Move your mouse pointer over one of these "resizing boxes". When the mouse pointer displays a 

double-headed arrow, hold down the left mouse button and drag the object to the desired size. 
There is also the option to move an object. To do this, move your mouse pointer until it displays a 
hand icon. Then hold down the left mouse button and drag the object to the desired location. We 
may also want to resize our detail section. To do this, move the mouse pointer over the bottom of 
the detail section until the pointer displays a double-headed arrow, then hold down the left mouse 
button and drag until the detail section is the desired size. The example below shows the results 
of resizing the objects and the detail section of the report. 

  
17. Select the ‘Label’ icon from the Toolbox, and create a page header. Once the Label icon has 

been selected, left-click in the Page Header Section of the report and drag to size the Label 
object. Enter the text that you'd like to see displayed on each page. 

What is the difference between using Report Wizard and creating manual reports? 
When using the Report Wizard to create a report, you are asked a variety of detailed questions 
regarding the record sources, fields, layouts and format that is desired. A report is produced based on 
the answers you provided. Unless you are an experienced Microsoft Access user and have created 
manual Access reports in the past, you will probably want to use the Report Wizard to provide you with 
the information you are looking for. 
 
 
 



Preview and print a report 
Preview a report 
When you want to see how your report will appear when printed, use Print Preview. If you preview a 
report that was created in Access, the record navigation buttons appear in the default location, at the 
bottom of the Access window. 
Start Print Preview 

1. If the report is not open, in the Navigation Pane, right-click the report that you want to preview, 
and then click Print Preview on the shortcut menu. 
-OR- 
If the report is open, right-click the document tab for the report and click Print Preview. 

2. Click the record navigation buttons to move among the pages in the report. 
Preview multiple pages 
If the report is open, right-click the document tab for the report and click Print Preview. 

1. On the Print Preview tab, in the Zoom group, click Two Pages to preview your report two pages at 
a time. 
-OR- 
In the Zoom group, click More Pages, and then select an option. 

2. Click the record navigation buttons to move among the pages in the report. 
3. To revert to previewing a single page, in the Zoom group, click One Page. 

Close Print Preview 
You can either print the report after previewing it or close the preview if you want to make changes to the 
report before printing it. 

 On the Print Preview tab, in the Close Preview group, click Close Preview. 
Print a report quickly 
If you want to print all the pages in the report without making any changes to the format of the report such 
as margins, headers, footers, and orientation (portrait or landscape) you can use the Quick Print option. 

1. If the report is not open, in the Navigation Pane, right-click the report and click Print. 
-or- 
Make sure that the Quick Print button is available in the Quick Access Toolbar. To add the button 
to the toolbar, click the down-arrow at the end of the toolbar and click Quick Print. 

2. On the Quick Access Toolbar, click Quick Print. 
Print selected pages from a report 
In a report, you can limit what you print only by selecting a range of pages. 

1. Click File and then click Print. 
2. On the Print area of the File options, click the Print option to open the Print dialog box. 
3. To print only some of the data in the report, under Print Range, click Pages, and then enter a 

value in the From and the To boxes. 
For example, to print just page 5 of a report, type 5 in both the From and the To boxes. 



If you own the necessary permissions to change the design of a report, you can make additional changes 
to the way that your report prints by changing the print layout in the Page Setup dialog box (click Setup 
to display the Page Setup dialog box). 
Change the page setup 
The Page Setup dialog box can be used to change a variety of print options, including the top and bottom 
margins and whether Access prints just the data in your report. Access provides two ways to display the 
Page Setup dialog box. You can start it from within the Print dialog box, or you can start it from the Print 
Preview tab, which appears when you start Print Preview. 
The steps in this section explain how to display the Page Setup dialog box. 
Start the Page Setup dialog box from the Print dialog box 
In the Navigation Pane, select the report that you want to change. You do not need to open the report, 
although you can if you need to ensure that the data you are about to print is current. 

1. Click File and then click Print. 
2. On the Print area of the File options, click the Print option to open the Print dialog box. 
3. Click Setup to display the Page Setup dialog box. 
4. Set or change the options in the dialog box, as needed.  

Start the Page Setup dialog box from the Print Preview tab 
1. In the Navigation Pane, right-click the report that you want to change and click Print Preview. 

Access opens the report in Print Preview. 
2. On the Print Preview tab, in the Page Layout group, click the Page Setup button. 
3. Set or change the options in the dialog box, as needed.  

Select print options 
Follow the steps when you need to print some of the pages in a report or when you need to select a 
printer or change print settings, such as margins or columns. 

1. In the Navigation Pane, select the report that you want to print. 
2. Click File and then click Print. 
3. On the Print area of the File options, click the Print option to open the Print dialog box. 
4. Change the page format setup or other print options or printer selection as needed, and then click 

OK to print your report. 
 
 

Built-in functions 
MS Access has many built-in functions. This reference contains the string, numeric, and date 
functions in MS Access. 
MS Access String Functions 
Function Description 
Asc Returns the ASCII value for the specific character 
Chr Returns the character for the specified ASCII number code 
Concat with & Adds two or more strings together 
CurDir Returns the full path for a specified drive 
Format Formats a value with the specified format 



InStr Gets the position of the first occurrence of a string in another 
InstrRev Gets the position of the first occurrence of a string in another, from the end of string 
LCase Converts a string to lower-case 
Left Extracts a number of characters from a string (starting from left) 
Len Returns the length of a string 
LTrim Removes leading spaces from a string 
Mid Extracts some characters from a string (starting at any position) 
Replace Replaces a substring within a string, with another substring, a specified number of times 
Right Extracts a number of characters from a string (starting from right) 
RTrim Removes trailing spaces from a string 
Space Returns a string of the specified number of space characters 
Split Splits a string into an array of substrings 
Str Returns a number as string 
StrComp Compares two strings 
StrConv Returns a converted string 
StrReverse Reverses a string and returns the result 
Trim Removes both leading and trailing spaces from a string 
UCase Converts a string to upper-case 
 
MS Access Numeric Functions 
Function Description 
Abs Returns the absolute value of a number 
Atn Returns the arc tangent of a number 
Avg Returns the average value of an expression 
Cos Returns the cosine of an angle 
Count Returns the number of records returned by a select query 
Exp Returns e raised to the power of a specified number 
Fix Returns the integer part of a number 
Format Formats a numeric value with the specified format 
Int Returns the integer part of a number 
Max Returns the maximum value in a set of values 
Min Returns the minimum value in a set of values 
Randomize Initializes the random number generator (used by Rnd()) with a 

seed 
Rnd Returns a random number 
Round Rounds a number to a specified number of decimal places 
Sgn Returns the sign of a number 
Sqr Returns the square root of a number 
Sum Calculates the sum of a set of values 
Val Reads a string and returns the numbers found in the string 
 

MS Access Date Functions 
Function Description 
Date Returns the current system date 
Dateadd Adds a time/date interval to a date and then returns the date 
DateDiff Returns the difference between two dates 
DatePart Returns a specified part of a date (as an integer) 
DateSerial Returns a date from the specified parts (year, month, and day 



values) 
DateValue Returns a date based on a string 
Day Returns the day of the month for a given date 
Format Formats a date value with the specified format 
Hour Returns the hour part of a time/datetime 
Minute Returns the minute part of a time/datetime 
Month Returns the month part of a given date 
MonthName Returns the name of the month based on a number 
Now Returns the current date and time based on the computer's system date and time 
Second Returns the seconds part of a time/datetime 
Time Returns the current system time 
TimeSerial Returns a time from the specified parts (hour, minute, and second value) 
TimeValue Returns a time based on a string 
Weekday Returns the weekday number for a given date 
WeekdayName Returns the weekday name based on a number 

 
MS Access Some Other Functions 
Function Description 
CurrentUser Returns the name of the current database user 
Environ Returns a string that contains the value of an 

operating system environment variable 
IsDate Checks whether an expression can be 

converted to a date 
IsNull Checks whether an expression contains Null 

(no data) 
IsNumeric Checks whether an expression is a valid 

number 
 
 

MACROS 
A macro is a stored series of commands that carry out an action or a string of actions. This feature can be 
used to add functionality or automate simple tasks, such as performing an action when the user clicks a 
command button. 
A macro in Access is a tool that allows you to automate tasks and add functionality to your forms, reports, 
and controls. For example, if you add a command button to a form, you associate the button's OnClick 
event to a macro, and the macro contains the commands that you want the button to perform each time it 
is clicked. 
In Access, it is helpful to think of macros as a simplified programming language that you write by building 
a list of actions to perform. When you build a macro, you select each action from a drop-down list and 
then fill in the required information for each action. Macros enable you to add functionality to forms, 
reports, and controls without writing code in a Visual Basic for Applications (VBA) module. Macros provide 
a subset of the commands that are available in VBA, and most people find it easier to build a macro than 
to write VBA code. 
For example, suppose that you want to start a report directly from one of your data entry forms. You can 
add a button to your form and then create a macro that opens the report. The macro can either be a 
standalone macro (a separate object in the database), which is then bound to the OnClick event of the 



button, or the macro can be embedded directly into the OnClick event of the button itself. Either way, 
when you click the button, the macro runs and opens the report. These types of macros are generally 
referred to as user interface macros. 
Features of Macro in Access 
In earlier versions of Access, many commonly used functions could not be performed without writing VBA 
code. In current versions of Access, new features and macro actions have been added to help eliminate 
the need for code. This makes it easier to add functionality to your database and helps make it more 
secure. 

1. Embedded macros : You have the ability to embed macros in any of the events provided by a 
form, report, or control. An embedded macro is not visible in the Navigation Pane; it becomes part 
of the form, report, or control in which it was created. If you create a copy of a form, report, or 
control that contains embedded macros, the macros are also present in the copy. 

2. Increased security : When the Show All Actions button is not highlighted in the Macro Builder, 
the only macro actions and RunCommand arguments that are available for use are those that do 
not require trusted status to run. A macro built with these actions will run even when the database 
is in disabled mode (when VBA is prevented from running). Databases that contain macro actions 
that are not on the trusted list —or databases that have VBA code — need to be explicitly granted 
trusted status. 

3. Error handling and debugging : Access provides macro actions, including OnError (similar to 
the "On Error" statement in VBA) and ClearMacroError, that allow you to perform specific actions 
when errors occur while your macro is running. In addition, the SingleStep macro action allows 
you to enter single-step mode at any point in your macro, so that you can observe how your 
macro works one action at a time. 

4. Temporary variables : Three macro actions (SetTempVar, RemoveTempVar, and 
RemoveAllTempVars) allow you to create and use temporary variables in your macros. You can 
use these in conditional expressions to control running macros, or to pass data to and from 
reports or forms, or for any other purpose that requires a temporary storage place for a value. 
These temporary variables are also accessible in VBA, so you can also use them to communicate 
data to and from VBA modules. 

Why use macros? 
Macros can perform a number of the common tasks that you can also use Visual Basic code to perform. 
With some research, non-programmers can quickly set up a macro and dramatically increase database 
productivity. 
Limitations of macros 

1. Macros functions are limited. You might find yourself searching for some help developing a 
custom VB code. Macros lack programming loops and advanced coding logic. 

2. Macros are not meant to be a permanent solution, and they take up more space than VB code. 
Luckily, you can use this function to develop prototype VBA code. 

3. Most professional Access developers use the VBA programming language for a richer and more 
powerful development environment. Over time, you’ll want to switch your Macro over to a VB 
code. 

4. Using Visual Basic code rather than macros gives you much more flexibility and power. Visual 
Basic provides much more functionality than macros such as returning values or iterating through 
record sets. 

 



Developing Macros 
If you do not have a programming background, you can use the macro feature to automate simple tasks 
through a series of drop down selections that Access has provided. 
Macros allow you to easily chain commands together such as running queries, importing or exporting 
data, opening and closing forms, previewing and printing reports, etc. Macros support basic ‘IF condition’ 
logic and the ability to call other macros. Macros can also contain sub-macros which are similar to 
subroutines. 
In Access 2007, macros are significantly enhanced with the inclusion of error handling and temporary 
variable support. Access 2007 also introduces embedded macros that are essentially properties of an 
object's event. This eliminates the need to store macros as individual objects. 
Designing a Macro 

1. Under “ Microsoft Access Create”, click the Macro button. 
 

  
The following Macro window screen should appear. 
 

  
2. In the Action column, click the arrow to display the list of available actions and select the action 

you want to use. There are several dozen actions to choose from. Depending on the action 
selected, you may have to specify Action Arguments. For example, if you select the OpenForm 
Action, the following Action Arguments appear for input. 
 

 



 
3. If you want to add more actions to the macro, move to another action row and select a new 

action. Note that Microsoft Access carries out the actions in the order you list them. 
4. To save the macro, click the Save button on the Quick Access Toolbar at the top of the screen 

and enter a name for your macro. Make sure you name this macro "AutoExec". By naming it 
AutoExec, Access will run this macro every time the database is opened. 
 

  
Create an event-driven data macro 
Table events occur whenever you add, update, or delete data within a table. You can program a data 
macro to run immediately after any of these three events, or immediately before a delete or change event. 
Use the following procedure to attach a data macro to a table event: 

1. In the Navigation Pane, double-click the table to which you want to add the data macro. 
2. On the Table tab, in the Before Events group or the After Events group, click the event to which 

you want to add the macro. For example, to create a data macro that runs after you delete a 
record from the table, click After Delete. 

Note: If an event already has a macro associated with it, its icon appears highlighted on the ribbon. 
3. Access opens the Macro Builder. If a macro was previously created for this event, Access 

displays the existing macro. 
4. Add the actions that you want the macro to perform. 
5. Save and close the macro. 

Edit an event-driven data macro 
1. In the Navigation Pane, double-click the table that contains the data macro that you want to edit. 
2. On the Table tab, in the Before Events group or the After Events group, click the event for the 

macro that you want to edit. For example, to edit the data macro that runs after you delete a 
record from the table, click After Delete. 

Edit a named data macro 
1. In the Navigation Pane, double-click any table to open it in Datasheet view. 
2. On the Table tab, in the Named Macros group, click Named Macro, and then point to Edit Named 

Macro. 
3. In the submenu, click the data macro that you want to edit. 
4. Access opens the Macro Builder, and you can begin editing the macro. 

Rename a named data macro 
1. In the Navigation Pane, double-click any table to open it in Datasheet view. 
2. On the Table tab, in the Named Macros group, click Named Macro, and then click 

Rename/Delete Macro. 



3. In the Data Macro Manager dialog box, click Rename next to the data macro that you want to 
rename. 

4. Access selects the current macro name. 
5. Type the new name or edit the existing name, and then press ENTER. 

Delete a data macro 
Use this procedure to delete any named or event-driven data macro: 

1. In the Navigation Pane, double-click any table to open it in Datasheet view. 
2. On the Table tab, in the Named Macros group, click Named Macro, and then click 

Rename/Delete Macro. 
3. In the Data Macro Manager dialog box, click Delete next to the data macro that you want to 

rename. 
Ms-Access Data Import 

Normally data is stored in various formats, files, and locations, which makes it hard to get and use it. If 
you have data in a spreadsheet, a SharePoint list, or some other format, you can import it into an Access 
database with just a few steps, making it much more, easily available in Access. 

 The Save As command is generally used to save a document in another format, so that you can 
open it in another program. 

 In Access you can’t use the Save As command in the same way, you can save Access objects as 
other Access objects, but you cannot save an Access database as a spreadsheet file. 

 To save Access as a spreadsheet file, you will need to use the import feature on the External 
Data tab. 

To understand what kind of data you can import in the Access data, let us open your database and go to 
the External Data tab. 
In the import group, you can see the different kind of options available for data import in Access. 
Following are the most commonly used data import formats. 

 Microsoft Office Excel 
 Microsoft Office Access 
 ODBC Databases (For example, SQL Server) 
 Text files (delimited or fixed-width) 
 XML Files 

Data importing from an Excel file 
1. On the ribbon, click External Data. 

2. In the Import section, click Excel  
3. In the Get External Data - Excel Spreadsheet, click Browse... 
4. Locate the folder that contains the resource file and select it. 
5. Select the .xlsx file and click Open. 
6. In the Get External Data - Excel Spreadsheet, click OK. 
7. In the first page of the wizard, click the Show Named Ranges radio button and, in the list, click 

any option. 
8. Click Next 
9. In the second page of the wizard, click the First Row Contains Column Headings check box. 



10. Click Next. 
11. In the third page of the wizard, accept all defaults and click Next. 
12. In the fourth page of the wizard, accept all defaults and click Next. 
13. Set the name of the table and click Finish. 
14. In the last page of the wizard, click Close. 
15. In the Navigation Pane, double-click the table to open it. 
16. Double-click ID, enter name and press Enter. 
17. Close the table. 

Importing data from the Access database 
1. In Import group, click on the Access option. 
2. Browse the Access database from which you want to import the data and then select the first 

option which says Import tables, queries, form etc. Now, click Ok. 
3. In the Import objects dialog box, you can see different tabs for Tables, Queries, Forms etc. from 

where you can select what kind of data you want to import. 
4. Let us go to the Reports tab and select any report you want to import; you can also select all the 

data by clicking on the Select All button.  
5. Now, close the dialog box. In the navigation pane, you will see that a new report is added. Let us 

open this report and you will see all the data in that report. 
Importing a Text Document 

1. On the Ribbon, click External Data. 
2. In the Import section, click Text File  
3. In the Get External Data - Text File dialog box, click the Browse button. 
4. Locate the resources and select it. 
5. Click .txt file and click Open. 
6. On the dialog box, click OK. 
7. On the first page of the Import Text Wizard, accept that the text be Delimited and click Next. 
8. In the second page, accept that the delimiter be set to Comma and check the box stating: First 

Row Contains Field Names. 
9. Click Next. 
10. Accept the defaults of the third page of the wizard and click Next. 
11. Accept to contents of the fourth page of the wizard and click Next. 
12. Accept to import to table and click Finish. 
13. You receive a confirmation message when the table has been imported. 
14. Click Close. 
15. In the Navigation Pane, double-click the table to open it. 
16. Double-click ID, type IDname and press Enter. 
17. Save and close the table. 

Importing an XML File 
1. On the Ribbon, click External Data 
2. In the Import section, click XML File XML File 
3. In the Get External Data - XML File dialog box, click the Browse button 
4. Locate the resources that accompany .xml files and select it. 
5. Click .xml file and click Open. 
6. In the list, click the node and accept to import both the structure and the data of the table. 
7. Click OK. 
8. You receive a confirmation message. Click Close. 



9. In the Navigation Pane, double-click the table to open it. 
10. Double-click ID, type IDname and press Enter. 
11. Close the table. 

Data Export 
Data export is actually the opposite of importing data. In importing data, we bring data from other formats 
in Access, while in exporting we save the data in other formats. 
To understand what kind of data you can export from Access data, let us open your database and go to 
the External Data tab. 

 
In the Export group, you can see the different kind of options available for data export from Access. 
Following are the most commonly used data export formats − 

 Microsoft Office Excel 
 Microsoft Office Access 
 ODBC Databases (For example, SQL Server) 
 Text files (delimited or fixed-width) 
 XML Files 

Exporting to a Microsoft Excel Spreadsheet 
1. Open your database where you want to export the data from.  
2. In the Navigation Pane, select the object that you want to export the data from. 
3. You can export the data from table, query, form, and report objects etc.  
4. On the External Data tab, click on the type of data that you want to export to. For example, click 

on Excel button to convert the data to excel form. 



  
5. Access starts the Export wizard. In the wizard, you can set the information such as the 

destination file name and format, whether to include formatting and the layout, which records to 
export. Once you are done with the required information, click Ok. 

  
6. On this screen of the Wizard, Access usually asks you if you want to save the details of the 

export operation. If you think you will need to perform the same operation on a recurring basis, 
select the Save export steps check box and close the dialog box. 

7. Then you can open the excel sheet where you save it. 
Exporting a Text File 
The easiest way to use data from a Microsoft Access database to an external application is to save it as 
plain text. The reason is that almost every application that deals with databases can import text and 
convert it into a spreadsheet or a database table. This is only possible if the text file is appropriately 
formatted. Fortunately, if you ask Microsoft Access to save a table to text, it would take care of formatting 
it. 
To save a table as text: 

1. In the Navigation Pane, click the table you want to export. On the Ribbon, click External Data 
and, in the Export section, click the Text File button 

2. In the Navigation Pane, right-click the table that holds the data, position the mouse on Export, 
and click Text File 

3. This would open the Export - Text File dialog box with the name of the file using the .txt 
extension. The default folder where the file would be saved is My Documents. If you want 
another, you can select it by clicking the Browse button. Once you are ready to export, you can 
click OK. This would open the Export Text Wizard that you can follow: 



  
4. You would have various options to specify how you want Microsoft Access to format the 

document. You would also choose whether to include the column headers or not. 
Assigning a Password to a database 

When you want to help prevent unauthorized use of an Access database, consider encrypting the 
database by setting a password. If you know the password for an encrypted database, you can also 
decrypt the database and remove its password.  
In earlier versions of Access, you could create user accounts and passwords using a feature named user-
level security. This topic does not discuss user-level security, which is not available when you use the 
.accdb file format. 
If you encrypt a database and then lose the password, you will be unable to use the database. You 
cannot remove a database password if you do not know the password. 
The encryption tool makes your data unreadable by other tools, and sets a password that is required to 
use the database. Remember these rules as you proceed: 

 The new encryption feature applies only to databases in the .accdb file format. 
 The tool uses a stronger encryption algorithm than was used in earlier versions of Access. 
 If you want to encode or apply a password to an earlier-version Access database (an .mdb file), 

Access uses the Encoding and Password features from Access 2003. 
Encrypt a database 

1. Open the database in Exclusive mode. 
How do I open a database in Exclusive mode? 

 On the File tab, click Open.  
 In the Open dialog box, browse to the file that you want to open, and then select the file. 
 Click the arrow next to the Open button, and then click Open Exclusive. The following 

figure depicts the menu. 

 2. On the File tab, click Info, and then click Encrypt with Password.  



3. The Set Database Password dialog box appears. 
4. Type your password in the Password box, type it again in the Verify box, and then click OK. 

Open and decrypt a database 
1. Open the encrypted database the way that you open any other database. 
2. The Password Required dialog box appears. 
3. Type your password in the Enter database password box, and then click OK. 

Remove a password 
1. Open the database in Exclusive mode. 

How do I open a database in Exclusive mode? 
 On the File tab, click Open.  
 In the Open dialog box, browse to the file that you want to open, and then select the file. 
 Click the arrow next to the Open button, and then click Open Exclusive. The following 

figure depicts the menu. 

 
2. On the File tab, click Info, and then click Decrypt Database. (Note, if you're using Access 2007 on 

the Database Tools tab, in the Database Tools group, click Decrypt Database.) 
3. The Unset Database Password dialog box appears. 

Type your password in the Password box, and then click OK. 
 

 
 

 
 
 
 


